What to do if the Preloader keeps disconnecting !

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#41
right! deleted everything plugged the phone with battery on,


driver detected as mtk usb port.


so whats next?! do i install some preloader driver or no?


 


 
yes install preloader drivers


 
 

mmf4cd

New Member
Feb 21, 2015
10
0
1
29
#42
Hey guys, just wanted to share some information with you regarding the preloader issue.


Some people got the problem that the preloader keeps disconnecting while using sp-flashtool and the bar stops or you get an error.


Try those things in this order :


1) Remove all Drivers with usbdeview (MTK preloader, MTK usb port, MTK VCOM port, android ADB...)


2) Reboot


3) Reinstall drivers ! (dont install too many different ones !)


4) Try to keep holding volume up while connecting or power + up ! Also keep holding that during the flash. Sometimes it stops after you relese the buttons.


5) Formatting your WHOLE FLASH ! could solve it. because it wipes the preloader. BUT ONLY DO THIS IF EVERYTHING ELSE FAILED !!!


On some phones it also could be a different button combo


I´m still looking for a fix on how to force the preloader to be connected.


But for now, make sure you try this !


 

I only find 1 vcom driver on my PC and I uninstalled and install again but still my phone is not showing on sp flash tool and I treid 2 different version of sp flashtool but the result was same.


I am getting a sound while connecting my phone to PC but nothing happening on sp flashtool.


Please help to solve this issue.


Thanks.


Regards


 
 

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#43
I only find 1 vcom driver on my PC and I uninstalled and install again but still my phone is not showing on sp flash tool and I treid 2 different version of sp flashtool but the result was same.


I am getting a sound while connecting my phone to PC but nothing happening on sp flashtool.


Please help to solve this issue.


Thanks.


Regards


 


 
check 'device manager' see what your device is connected as..if it is not 'mtk usbvcomm' then the driver is not installed correctly and will need to be reinstalled either by connecting the device without battery whilst holding vol- or vol+ or by 'updating driver' in device manager


 
 

Why_me

New Member
Mar 6, 2015
3
0
1
#44
Hi fellows,


I'm facing the same issue.


Today I've got a brand new Cynus T6 and was trying to back it up.


I've installed all drivers and everything seemed to be ok.


But when I was trying to readback from flash with (SP_Flash_Tool_v5.1352.01)  I always got a window popping up which says: BROM ERROR: S_FT_READBACK_FAIL (4009).


This happens always after 13 minutes (somewhat 650 MByte).


I've done everything with that USB-stuff, but nothing changed.


At least I took my old and slow Laptop (also WIN 7) and installed everything from scratch. And believe it or not: with a much slower USB connection it also took about 13 minutes (450 MByte) to show me that lovely BROM ERROR.


So I don't think, that it's (only) an USB-issue.


And now it's 2 hours after midnight and I try to get some sleep.....


See you.
 

Percymama

Super Moderator
Super Moderator
Mar 19, 2014
4,646
1,546
113
Cornwall United Kingdom
#45
Hi


You can try different versions of SPFT and see if that helps


http://www.china-devices.com/Thread-13-different-versions-of-sp-flash-tool-extra-newest-version-found-by-blandroid
 

Why_me

New Member
Mar 6, 2015
3
0
1
#46
WOW!!


That was it. Thank you very much Percymama!


I don't know why I didn't find that Version (SP_Flash_Tool_exe_Windows_v5.1452.00.000) earlier, but it is a real rocket.


It is 6 times faster than the other one and it took only 3:12 min to download 1GByte.


Everything seems to be ok now and the sun is shining brighter... ;-)


Thanks again, have a good day.


Kind Regards
 
Apr 11, 2015
3
0
1
#48
Hello!


i don't understand i can't unbrick my phone since a week..and i'm frustrated...thi is th story:


My phone is Elephone p6000 and i decided to sell and buy a meizu so i clock on reset in android settings but when i power up it asks me for a password protection privacy so i google it and i find that i have to reflash the stock rom.


But when i connect the phone it appears and disappear every 2 seconds and its recognized as mtk preloader...if i click on power+volume down it changes in mtk usb port...so i go to sp tool adn select the scatter file from the stock rom i downloaded, press download, press volume down + power and connect the phone but after 1 minute it pop up this error:





any graceful help???
 

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#49
Hello!


i don't understand i can't unbrick my phone since a week..and i'm frustrated...thi is th story:


My phone is Elephone p6000 and i decided to sell and buy a meizu so i clock on reset in android settings but when i power up it asks me for a password protection privacy so i google it and i find that i have to reflash the stock rom.


But when i connect the phone it appears and disappear every 2 seconds and its recognized as mtk preloader...if i click on power+volume down it changes in mtk usb port...so i go to sp tool adn select the scatter file from the stock rom i downloaded, press download, press volume down + power and connect the phone but after 1 minute it pop up this error:





any graceful help???
hey francesco,


please can you create a new thread in hardware and software support as you have more than one issue once you create that thread i will move this post over to it


and to answer your question...first try to flash the rom without the preloader...untick this option before pressing 'download' in sp flash tool as your preloader is ok and does not need to be reflashed


if this does not work then try JUST holding VOL- nothing else keep it held press download in sp flash tools then connect the device to the p.c.


https://www.china-devices.com/Thread-All-Sp-Flashtool-Error-Codes


 


(2005) S_BROM_CMD_STARTCMD_FAIL


When you flash preloader and you get this, be sure to connect the phone in META mode (press volume down while connecting and hold) Otherwise while flashing the preloader this error can pop up.
 

sojo

New Member
Apr 15, 2015
1
0
1
#50
Please I seriously need help before I finally make up my mind to throw this phone into a blazing fire.


I apologise for posting in the wrong place (I don't know how to start a new thread here)


My phone is a Tecno f7(A+) and it's being hard bricked now for over a month. I've tried almost everything I can lay my hands on on the internet not working. I guess this is my last stop.


The state of the phone now is that when I try to flash I have the popular Brom Error, Dram failed, error (4032).


I have used usbdeview to uninstall everything mtk on my pc, I have tried 2 other pcs, I have deleted all my flashtools, drivers stock roms and downloaded new ones, but the phone refused to wake up.


When I connect the phone to pc now it doesnt recognise as preloader, what it shows in device manager is mtk usb port, and it keeps connecting and disconnecting.


I was able to manually update to VBCOM port but still the same error when I try to flash, I guess because of the connecting and disconnecting issue.


I believe, I have the correct stock ROM as I have used the same to unbrick another phone of the same model before. Although to give benefit of doubt I tried to get another ROM from needrom but I couldn't get one for Tecno phantom A+ there.


I hope my long story will make somebody provide any assistance.


Thanks.


I left my phone for a while after I have tried to no avail, i just decided not to just let go like that and picked up again today. I have tried 3 different PCs but still the same issue.


I've tried to manually install the drivers, I still have the DRAM ERROR issue.


Now if I connect the phone to any of the systems(without battery) it shows MTK USB Port in device manager instead of Preloader that shows when I plug in another working Tecno A+


and the keeps connecting and disconnecting.


Even if I install the drivers using the working phone and its installed as Preloader on say COM 190 when I plug in my own phone to flash it will still not pick that on COM but instead pick the on COM 189 or a new COM 191 as MTK USB Port and then the DRAM ERROR pops up again.
 
Last edited by a moderator:

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#51
hey sojo,


first of all you can post this thread in the link below just create a new thread with the box in the top right hand side when you enter the link


 


https://www.china-devices.com/Forum-Hardware-Software-Support


 


as for your problem,try pressing and holding vol- before connecting the device...so go through all the motions load scatter,press download,then connect the device as described above...if vol- does not work then try vol+ instead...this is called META mode and should trigger the preloader to flash the rom
 

gremlin9

New Member
Apr 29, 2015
19
4
3
#52
I followed how to get the preloader but when I put usb on my bricked phone it shows up as a port  mediatek preloader usb vcom (com7) but then it keeps disappearing and does this until I remove usb from phone.   How do I get this to stop.   I have tried reinstalling drivers but get same result.
 
Oct 11, 2014
17
0
1
#53
Hey guys, just wanted to share some information with you regarding the preloader issue.


Some people got the problem that the preloader keeps disconnecting while using sp-flashtool and the bar stops or you get an error.


Try those things in this order :


1) Remove all Drivers with usbdeview (MTK preloader, MTK usb port, MTK VCOM port, android ADB...)


2) Reboot


3) Reinstall drivers ! (dont install too many different ones !)


4) Try to keep holding volume up while connecting or power + up ! Also keep holding that during the flash. Sometimes it stops after you relese the buttons.


5) Formatting your WHOLE FLASH ! could solve it. because it wipes the preloader. BUT ONLY DO THIS IF EVERYTHING ELSE FAILED !!!


On some phones it also could be a different button combo


I´m still looking for a fix on how to force the preloader to be connected.


But for now, make sure you try this !


pls bro try and make a video of flashing mtk 6592 a phone that is bricked but keeps going off and on when plugged to  a wall socket with electrical charger as well as usb to pc.... and as well spflashtool version 5 i have tried most of the ones i found on this web pagebut they be all giving the not responding notification each time the flash files are selected for flashing..do you have any solution? if ya pls help by making the videos ..my os version is 8.1 thnx
 

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#54
kennykendo,


you may have to disable 'driver signature enforcement' on your p.c.


reboot...keep pressing F8,scroll down to driver sig enforcement' and disable it,then reboot and try installing the drivers again


 


also maybe you have a broken usb/micro usb cable...have you tried with different cables
 
Last edited by a moderator:
Jul 20, 2015
1
1
3
#55
Hi all!

 

Have the same problem with my THL T6S MTK6582 phone. I've tried steps 1-4, but without a success? Maybe there's another combo in my phone?

Is there a solution for prevent the preloader from disconnecting, except from formatting the whole flash? :( 
 
Likes: mrsim

sanjay59

New Member
Oct 22, 2015
6
6
3
#56
i have the same problem in mtk 6582 phone preloader is disconnect phone after 2 seconds is there any way to connect this phone to pc i have use all the method. please help me.
 
Likes: mrsim

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#57
i have the same problem in mtk 6582 phone preloader is disconnect phone after 2 seconds is there any way to connect this phone to pc i have use all the method. please help me.
it is normal for the preloader to disconnect after this time...do not worry...so long as you see 'mtk usb vcom' drivers in device manager/ports,(keep device manager open when you connect to check you have to quickly click on ports when you see it pop up),this just means the drivers are working and you can go ahead and flash the device using meta mode to connect to sp flash tools
 

sanjay59

New Member
Oct 22, 2015
6
6
3
#58
it is normal for the preloader to disconnect after this time...do not worry...so long as you see 'mtk usb vcom' drivers in device manager/ports,(keep device manager open when you connect to check you have to quickly click on ports when you see it pop up),this just means the drivers are working and you can go ahead and flash the device using meta mode to connect to sp flash tools
thank mrsim i flash my rom and my phone is back now but i am facing wrong imei number problem can you help me to store my imei number back in phone. thank you again for your help.

one more help is needed from you to stor imei number
 
Likes: mrsim

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#59
thank mrsim i flash my rom and my phone is back now but i am facing wrong imei number problem can you help me to store my imei number back in phone. thank you again for your help.

one more help is needed from you to stor imei number
go to our tutorial section there are a few threads there which will help you out.... :dance2:
 

peekeith

New Member
Nov 20, 2015
25
16
3
Mandaluyong, Philippines
#60
done everything what has been instructed. but still nothin appears on the screen. still lifeless. btw. im using the latest sp flashtool (v5.1524.0). and my phone is a s5 clone mt6571 sm-g900h (as far as i know, when droidtools used to detect my android before it got bricked). and the reason why my phone was bricked because of chainfire 3d. and to make the problem worse... i got no backups for it . (the xxxx.md5) anyone??? am i missing something??? thanks
 
Likes: mrsim