What to do if the Preloader keeps disconnecting !

itxtutor

Editor in Chief
Staff member
May 15, 2015
60,104
471
113
#1
Hey guys, just wanted to share some information with you regarding the preloader issue.


Some people got the problem that the preloader keeps disconnecting while using sp-flashtool and the bar stops or you get an error.


Try those things in this order :


1) Remove all Drivers with usbdeview (MTK preloader, MTK usb port, MTK VCOM port, android ADB...)


2) Reboot


3) Reinstall drivers ! (dont install too many different ones !)


4) Try to keep holding volume up while connecting or power + up ! Also keep holding that during the flash. Sometimes it stops after you relese the buttons.


5) Formatting your WHOLE FLASH ! could solve it. because it wipes the preloader. BUT ONLY DO THIS IF EVERYTHING ELSE FAILED !!!


On some phones it also could be a different button combo


I´m still looking for a fix on how to force the preloader to be connected.


But for now, make sure you try this !
 
Last edited by a moderator:
Likes: mrsim

Teflex

New Member
Aug 30, 2014
19
0
1
#2
hi i have to update my driver and i am not quite sure how to do it i messed up my computer before trying to get round this just got back on track after 2 hours not going well any help for a dummy


OK sorry i have just seen your video on you tube so gonna give it a go  thanks
 
Last edited by a moderator:
Sep 3, 2014
1
0
1
#3
Hi 


I tried every step (except #5) and still it keeps appearing and disappearing and showing the yellow triangle on the device manager. Also when I plug it in while pressing vol. up it appears a kinda console stuff on the phone screen saying "boot" but it disappears after a few seconds as the preloader disappears.


Any ideas?


Thanks
 

itxtutor

Editor in Chief
Staff member
May 15, 2015
60,104
471
113
#4
if it does disocnnect only once its ok.


if it does the whole time its fucked up.


So connect it with open device manager. as soon as you see the yellow triangle, right click, and point to the VCOM DRIVER. Just be fast
 
Last edited by a moderator:

dan2dons

New Member
Jan 19, 2015
5
0
1
53
#9
Yup, same problem. I cant install the drivers because the device isnt recognised at plugged in long enough. I've tried keeping the volume- button pressed but all it does is switch between connected and unconnected with no opportunity to install the drivers.


Tried different cables, different USB ports and different PCs, all the same problem...so it must be the device!!


Desperate to flash to 4.4.2 with 4gb so any help really appreciated!! 
 

itxtutor

Editor in Chief
Staff member
May 15, 2015
60,104
471
113
#10
you should also be able to quickly do rightclick install drivers.


but if that doesnt work either, you should try the hardware mod
 

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#12
hardware mod? can you point me to where i can start my research?
just be aware this involves taking your device apart to access the main board


 


http://www.china-devices.com/Thread-How-to-unbrick-every-china-phone-Hardware-Prelaoder-Mod
 
Feb 24, 2015
14
0
1
#15
The thing is quite simple for me. i closed my phone and it never came back on.


the phone is an elephone p6i. i keep getting the brom 4032 error.


The phone is recognized as an mtk usb port.


 i managed to install the mediatek usb vcom drivers manually but as soon as i flash it i keep getting the 4032 error. any ideas without dismantling the phone?
 

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,207
2,366
113
47
London UK
#16
The thing is quite simple for me. i closed my phone and it never came back on.


the phone is an elephone p6i. i keep getting the brom 4032 error.


The phone is recognized as an mtk usb port.


 i managed to install the mediatek usb vcom drivers manually but as soon as i flash it i keep getting the 4032 error. any ideas without dismantling the phone?
here is a list of all the sp flash tools error codes that we have been able to find online


 


http://www.china-devices.com/Thread-All-Sp-Flashtool-Error-Codes


 


http://www.china-devices.com/Thread-Checklist-How-To-Fix-SP-Flash-tool-errors-and-problems
 

Percymama

Super Moderator
Super Moderator
Mar 19, 2014
4,646
1,546
113
Cornwall United Kingdom
#19
Have you tried ALL the SPFT Versions? this can help with the 4032 error message


http://www.china-devices.com/Thread-13-different-versions-of-sp-flash-tool-extra-newest-version-found-by-blandroid


You can also try an older Windows OS like Windows 7 or XP - that also helps in some cases
 
Feb 24, 2015
14
0
1
#20
i tried on all sp tools you listed, half of the tell me that the scatter file is not legal,


the rest gives me either 4032 and 4001 error.


The phone keeps connecting-disconecting throu the flashing progress.