Leagoo Lead 4 black sreen after Flashing stock ROM (SOLVED)

2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
this thread has now been moved to the phone tutorials section because it is now a fix for many users and also stickied

GREAT WORK

Have this Leagoo Lead 4 which at first have problem stuck at startup/boot. So i tried hard reset it first but it not fix the problem.
Then I tried download it stock firmware form needrom and flashing it with SP Flash Tool which done without any error.
But when I turn it on, only black screen and some white strip at bottom of screen appear. I think the hp turn on normal just the screen is mess up since I can unlock the hp and the hardware button (Back button, Home button) are response to my touch. I don't think the screen is broken.
When I try connect the phone to computer, it still get detected.
 

From what I find on my search, people with same country with me face the same problem when they tried to flash their Lead 4 with downloaded stock rom.
So I hope if anyone can from Malaysia have Leagoo Lead 4 can upload you backup rom. 
Or if there any way to solve this problem cause I don't know what to do any more since I try download twice this stock rom from different website. :(

I tried memory test, this is what I got.

============ Memory Detection Report ===========

Internal RAM:


External RAM:

Type = DRAM

Size = 0x20000000 (512MB/4096Mb)

NAND Flash:

ERROR: NAND Flash was not detected!

EMMC:

EMMC_PART_BOOT1 Size = 0x0000000000400000(4MB)
EMMC_PART_BOOT2 Size = 0x0000000000400000(4MB)
EMMC_PART_RPMB Size = 0x0000000000400000(4MB)
EMMC_PART_GP1 Size = 0x0000000000000000(0MB)
EMMC_PART_GP2 Size = 0x0000000000000000(0MB)
EMMC_PART_GP3 Size = 0x0000000000000000(0MB)
EMMC_PART_GP4 Size = 0x0000000000000000(0MB)
EMMC_PART_USER Size = 0x00000000e9000000(3728MB)

UPDATE: luckly I Readback the phone before I do anything to it. So I reflashing back the backup to the phone. It turn on okey now since I can see the Logo and I'm not surprise the Bootloop is still there. LOL
 
Last edited by a moderator:
10
Feb 20, 2015
38
0
18
19
Europe,Macedonia,Bitola
it is probably the cache making the bootloop try to clear the cache and factory reset after flashing or reflash it with sp flash tool without the cache and data

 
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
I tried it, but still same, since the phone already have bootloop before I backup it.
And the only reason I backup it just for precaution before I flashing another Stock rom for this phone that I downloaded from internet. 
 
30

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,174
1
113
48
London UK
the problem you seem to be having is with the display driver the only thing i can suggest is to try using the one of the roms you downloaded and replace the 'UBOOT' or 'LK.BIN' file with your backup one and see if this solves the issue....as for the bootloop...maybe try 'auto format' with sp flash tools first...then try flashing your backup again and see if this helps

 
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
the problem you seem to be having is with the display driver the only thing i can suggest is to try using the one of the roms you downloaded and replace the 'UBOOT' or 'LK.BIN' file with your backup one and see if this solves the issue....as for the bootloop...maybe try 'auto format' with sp flash tools first...then try flashing your backup again and see if this helps

 
Thanks it works!

I use the 'UBOOT' or 'LK.BIN' from the backup file and flash it with downloaded rom. 
Everything runs okey but as soon it screen turn off/lock, then when I try to unlock it the screen become glitch or look like a broken screen.
And also the IMEI gone now since I auto format the phone. But I will dealt it later.  
Now I try to update the phone hoping the glitch got fix. But if you guys have any idea how to fix it, I will try it.
I will update later.
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
Thanks for the Tutorial Imei fix,

now I need find way to fix the glitch screen after unlock the phone. Because even after I update the phone still glitch screen wont fix.
 
 
30

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,174
1
113
48
London UK
almost 100% certain it is the display drivers...although have you checked inside the device to see if the display connector is ok...? also you said you tried flashing two different roms try the lk.bin files from each of them and experiment to see if other may work...also as a last resort you can try different lk.bin files from almost any other mtk6572 rom that has the same display res as yours

p.s. forgot to ask...have you ever dropped the device as this could also be the cause...try having a good look at it when the screen is off and check for any cracks underneath the surface of the device screen even small tiny ones
 
Last edited by a moderator:
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
I think I agreed with you this may cause of the display drivers. Cause I try to reproduce the problem without off the screen like tapping the body of the phone or shake it but the screen okey untill the screen off the glitch came.

Actually this phone to belong to my friend, he ask my help if I can fix it. So I'm not sure if ti ever dropped. But from what i see on the cover of the phone there a little bit of scratch.

So, my only option is to find suitable lk.bin for this devices.
 
30

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,174
1
113
48
London UK
that's your only option for software...as for hardware you may have to open the device up and check the digitizer connection and make sure it is connected ok and also check the device for a cracked digitizer as well at the same time...just be very careful and do not break it...take your time and if you are unsure post here and we will try to help you out
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
Opening the devices is my last option since I don't have a right tool to open a phone.

For now I try my best to find the right display driver for this phone.
But looking at bright side, the phone now not bootloop anymore after 2 day I try to fix it and also the Imei got fix already. yeah :clapping:

this i copy from Mtk Droid root & tool just for more info.

Hardware : MT6572
Model : Lead4
Build number : HQ1400_C2_Lead_V0.1.3_20140821
Build date UTC : 20140821-022945
Android v : 4.2.2
Baseband v: MOLY.WR8.W1315.MD.WG.MP.V1.P14, 2014/08/21 10:18
Kernel v : 3.4.5 (release@release22) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP Wed Feb 11 13:01:32 CST 2015
Uboot build v : -----
LCD Driver IC : 1-hct_rm68172_dsi_vdo_wvga_cpt
 
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
For some reason after awhile I let the phone to screen off. When I turn on it the glitch has gone. :dntknw:
I turn off the devices and turn it again. Screen off it then turn on the screen again. 
I do the same same thing for a few times. Still the there is no glitch in the screen.

I don't know what happen but I seem like it got fix by it self or not. So I give it a day to say if the glitch came back.
 
30

mrsim

KingOfNoobs
Staff member
Mar 1, 2014
16,174
1
113
48
London UK
Opening the devices is my last option since I don't have a right tool to open a phone.

For now I try my best to find the right display driver for this phone.
But looking at bright side, the phone now not bootloop anymore after 2 day I try to fix it and also the Imei got fix already. yeah :clapping:

this i copy from Mtk Droid root & tool just for more info.

Hardware : MT6572
Model : Lead4
Build number : HQ1400_C2_Lead_V0.1.3_20140821
Build date UTC : 20140821-022945
Android v : 4.2.2
Baseband v: MOLY.WR8.W1315.MD.WG.MP.V1.P14, 2014/08/21 10:18
Kernel v : 3.4.5 (release@release22) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP Wed Feb 11 13:01:32 CST 2015
Uboot build v : -----
LCD Driver IC : 1-hct_rm68172_dsi_vdo_wvga_cpt 
as you can see unless you press the 'root' button and get a green box in the bottom left corner of mtk droid tools then your display driver,UBOOT), will not be displayed...wow so maybe it's fixed after all...nice one...if it stays this way you should make a full mtk droid tools backup and keep that in a folder somewhere....good work... :clapping:
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
Okey, after a few hour, I find out how the screen glitch got fixed.

When I tried to fix the invalid Imei, which the "Mtk Droid root & tool" requesting root from the phone.
So as usual, I use "To process file ROM_ from FlashTool" to patch the default recovery into CWM recovery so I can install Su via recovery.
(And also have to patch the boot.img since the phone have "recovery-from-boot.p" which can restore the factory recovery when it get modified.)

So this two patched file "recovery.img" and "boot.img" (from my backup rom), I flash it to the phone and some how the glitch got fixed. :dntknw:
To make sure of it, I tried flash the unpatch recovery and boot img and guess what? The glicth come back. :laugh2: LOL

Using the CWM recovery have the downside, the phone will not able to be update anymore since it only wanted to use the factory recovery to update it.
But who care LOL, it CWM recovery and the glitch is fixed. It a win, win situation. 

Other things, I already get the phone root (Green box) but it didn't show the UBOOT build Version. :dntknw:

So I'm glad to say my problem is solve.. Yeahh :clapping: ,, Thank mrsim for helping.
And I also include patched "boot.img", "recovery.img" and "Uboot.bin" from my backup just in case if someone have same problem.

View attachment 1235

View attachment 1236

View attachment 1237
 
2

heow1711

New Member
Aug 20, 2015
5
0
3
Hello,may i know use what software to put the above file to flash the lead 4 black screen?

 
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
 

Hello,may i know use what software to put the above file to flash the lead 4 black screen?

 
Hi, I use Sp Flash Tool .But before that, may I know how did you Lead 4 get black screen?
The Lead 4 I have, it have black screen cause I flash it with Stock rom that I downloaded.
Apparently the Uboot.bin deos not suitable with Lead 4 that I have.
 
2

heow1711

New Member
Aug 20, 2015
5
0
3
Same with you

 
 
2

heow1711

New Member
Aug 20, 2015
5
0
3
How can i put the attachment file to SP Tool Flash?
 
2

Sa1ne

New Member
Aug 19, 2015
19
0
3
: Malaysia
same as when you flash the download rom.
But click under Location , so you add different file instead the downloaded Rom file. 

BOOTIMG = Lead4_140821__boot_patched_150819-215248.img
RECOVERY = Lead4_140821__recovery_150819-215248.img
UBOOT = uboot.bin


And just precaution, UNTICK Box for PRELOADER.
Also I have a feeling  you don't really know How to flash and using the SP flash tool (Sorry). So please find out more info and learn more about how to use Sp Flash tool.
I wish I can teach you, but I very bad at teaching people.

Edit: Here I found link Guide using Sp flash tool. (http://www.china-devices.com/topic/48-spflash-tool-guide/)

 
 
Last edited by a moderator:
Help Users

You haven't joined any rooms.

    You haven't joined any rooms.